This is the complete list of members for ACAPI::Result< T, E >, including all inherited members.
Expect(std::string_view message) const | ACAPI::Result< T, E > | inline |
IsErr() const | ACAPI::Result< T, E > | inline |
IsOk() const | ACAPI::Result< T, E > | inline |
Map(Func func) const | ACAPI::Result< T, E > | inline |
MapError(Func func) const | ACAPI::Result< T, E > | inline |
operator*() & | ACAPI::Result< T, E > | inline |
operator*() && | ACAPI::Result< T, E > | inline |
operator*() const & | ACAPI::Result< T, E > | inline |
operator->() | ACAPI::Result< T, E > | inline |
operator->() const | ACAPI::Result< T, E > | inline |
OrElse(Func func) const | ACAPI::Result< T, E > | inline |
Otherwise(Func func) const | ACAPI::Result< T, E > | inline |
Result (defined in ACAPI::Result< T, E >) | ACAPI::Result< T, E > | friend |
Result(types::Ok< T > ok) | ACAPI::Result< T, E > | inline |
Result(types::Err< E > err, const API_Token &token) | ACAPI::Result< T, E > | inline |
Result(Result &&other) | ACAPI::Result< T, E > | inline |
Result(const Result &other) | ACAPI::Result< T, E > | inline |
Result(Result< U, E > &&other) | ACAPI::Result< T, E > | inlineexplicit |
Result(const Result< U, E > &other) | ACAPI::Result< T, E > | inlineexplicit |
Storage() const | ACAPI::Result< T, E > | inline |
Storage() | ACAPI::Result< T, E > | inline |
Then(Func func) const | ACAPI::Result< T, E > | inline |
Token() const | ACAPI::Result< T, E > | inline |
Unwrap() && | ACAPI::Result< T, E > | inline |
Unwrap() const & | ACAPI::Result< T, E > | inline |
Unwrap() & | ACAPI::Result< T, E > | inline |
UnwrapErr() const | ACAPI::Result< T, E > | inline |
UnwrapOr(const U &defaultValue) const & | ACAPI::Result< T, E > | inline |
~Result() (defined in ACAPI::Result< T, E >) | ACAPI::Result< T, E > | inline |