Archicad 28 C++ API
Loading...
Searching...
No Matches
Geometry Namespace Reference

Classes

class  GJKResult
 

Functions

template<typename VectorType >
VectorType GJKGetAveragePoint (const GS::Array< VectorType > &vertices)
 
template<typename VectorType >
VectorType GJKGetFurthestPoint (const GS::Array< VectorType > &vertices, const VectorType &d)
 
template<typename VectorType >
VectorType GJKGetSupport (const GS::Array< VectorType > &vertices1, const GS::Array< VectorType > &vertices2, const VectorType &d)
 
template<typename Coordinate >
bool GJKDoSimplex (GS::Array< Vector2< Coordinate > > &simplex, Vector2< Coordinate > &direction)
 
template<typename Coordinate >
bool GJKDoSimplex (GS::Array< Vector3< Coordinate > > &simplex, Vector3< Coordinate > &direction)
 
template<typename SupportFunction , typename VectorType >
GJKResult< VectorType > GJKCollisionDetection (SupportFunction supportFunction, VectorType direction)
 
template<typename VectorType >
GJKResult< VectorType > GJKCollisionDetection (const GS::Array< VectorType > &vertices1, const GS::Array< VectorType > &vertices2)
 

Detailed Description

Author
BLZ