Archicad 27 C++ API
Loading...
Searching...
No Matches
API_Coord Struct Reference

A pair of Cartesian (real) coordinates. More...

#include <APIdefs_Base.h>

Public Attributes

double x
 Horizontal coordinate.
 
double y
 Vertical coordinate.
 

Detailed Description

A pair of Cartesian (real) coordinates.

Remarks
It is a real coordinate. Always expressed in meters, if no other instructions are given in the corresponding documentation. For the integer type representation refer to the API_Point structure, or to the ACAPI_View_CoordToPoint and ACAPI_View_CoordToPoint functions for the conversion algorithms.