Archicad 28 C++ API
|
This is the complete list of members for API_ElemType, including all inherited members.
API_ElemType()=default | API_ElemType | |
API_ElemType(API_ElemTypeID typeID) | API_ElemType | inline |
API_ElemType(API_ElemTypeID typeID, API_ElemVariationID variationID) | API_ElemType | inline |
API_ElemType(const API_Guid &classID) | API_ElemType | inline |
classID | API_ElemType | |
GenerateHashValue(void) const | API_ElemType | inline |
operator!=(const API_ElemType &other) const | API_ElemType | inline |
operator!=(API_ElemTypeID otherTypeID) const | API_ElemType | inline |
operator!=(const API_Guid &otherClassID) const | API_ElemType | inline |
operator=(API_ElemTypeID newTypeID) | API_ElemType | inline |
operator=(const API_Guid &newClassID) | API_ElemType | inline |
operator==(const API_ElemType &other) const | API_ElemType | inline |
operator==(API_ElemTypeID otherTypeID) const | API_ElemType | inline |
operator==(const API_Guid &otherClassID) const | API_ElemType | inline |
typeID | API_ElemType | |
variationID | API_ElemType |