Archicad 28 C++ API
Loading...
Searching...
No Matches
API_FileOpenPars Struct Reference

Parameters to open a new project file. More...

#include <APIdefs_Automate.h>

Public Attributes

API_FTypeID fileTypeID
 file format to open
 
bool libGiven
 archiveLibSpec is passed or not
 
bool useStoredLib
 try to load the libraries specified in the project file. If the stored paths do not exist, the Library Manager dialog appears. In the Archive project file, the folder chooser dialog appears for selecting the appropriate library folder. This field is ignored if libGiven is true.
 
bool enableSaveAlert
 Show the "Save the current document before closing" alert or automatically save it before closing.
 
IO::Location * file
 specification of the target file to open
 
IO::Location * archiveLib
 library folder to create if archive open (optional), nullptr otherwise
 

Detailed Description

Parameters to open a new project file.

Remarks
For the utilization of this structure, see the ACAPI_ProjectOperation_Open automation function.