Archicad 28 C++ API
Loading...
Searching...
No Matches
API_IFCRelationshipData Struct Reference

Contains IFC Entity relations which are specific for the IFC. The IFC Entities are represented by their GlobalId. More...

#include <APIdefs_Automate.h>

Public Attributes

GS::HashTable< GS::UniString, GS::UniString > containmentTable
 IFC containment tree in "child->parent" format.
 
GS::HashTable< GS::UniString, GS::UniString > relFillsTable
 Relationships between openings (Doors/Windows/Skylights) and IfcOpeningElements (voids).
 
GS::HashTable< GS::UniString, GS::UniString > relVoidsTable
 Relationships between IfcOpeningElements (voids) and their parent IfcWall or IfcSlab.
 
GS::HashSet< GS::Pair< GS::UniString, GS::UniString > > assignmentTable
 IFC Assigment links, IfcGroup, IfcZone, IfcSystem, IfcRelAssignsToGroup and IfcRelServicesBuildings.
 
GS::HashTable< GS::UniString, GS::UniString > typeProductTable
 IFC Type Products tree.
 

Detailed Description

Contains IFC Entity relations which are specific for the IFC. The IFC Entities are represented by their GlobalId.

Remarks
This structure is used in ACAPI_ProjectOperation_Save. The IFC containment tree (containmentTable) is in "child ->parent" format. Example: IfcBuilding ->IfcProject IfcSite ->IfcBuilding IfcBuildingStorey ->IfcBuilding IfcWall ->IfcBuildingStorey IfcBuildingElementPart ->IfcWall. The IFC assignmentTable set (assignmentTable) is in "child ->parent" format. Example: IfcWall ->IfcRelAssignsToGroup IfcRelAssignsToGroup ->IfcGroup. The IFC Type Products (typeProductTable) is in "child ->parent" format. Example: IfcWall ->IfcWallType.