Archicad 27 C++ API
Loading...
Searching...
No Matches
API_PetPaletteType Struct Reference

Parameters for performing user input with pet palette. More...

#include <APIdefs_Interface.h>

Public Attributes

short petPaletteID
 Unique identifier of the pet palette.
 
short nCols
 Number of columns in the picture.
 
short nRows
 Number of columns in the picture.
 
short value
 The actual value of the control (starts from 1).
 
UInt32 grayBits
 The disabled items of the control.
 
short ** petIconIDsHdl
 Handle of the array of the 'GICN' resource IDs of the pet items; each item should be 22x22 pixels.
 
short dhlpResourceID
 'DHLP' resource ID (the tooltip and help anchor pairs).
 
short obsolete
 Previously used to be toolTipStrListID, now obsolete, not used.
 
GSResModule petIconResModule
 Resource module to load the icon resource from.
 

Detailed Description

Parameters for performing user input with pet palette.

Remarks
This structure holds the input parameters for the ACAPI_Dialog_PetPalette interface function. The help handling is changed because of the new help system. There are help anchor strings instead of the context help texts now, and tooltip strings. You should use the 'DHLP' resource, you can store the tooltip string and context help anchor pairs in one resource. For more details see ACAPI_Dialog_PetPalette.