Archicad 28 C++ API
Loading...
Searching...
No Matches
API_SavePars_Pdf Struct Reference

Contains the different page options for saving to pdf file. More...

#include <APIdefs_Automate.h>

Public Attributes

float leftMargin
 The size of the left margin of the page in mms.
 
float topMargin
 The size of the top margin of the page in mms.
 
float rightMargin
 The size of the right margin of the page in mms.
 
float bottomMargin
 The size of the bottom margin of the page in mms.
 
float sizeX
 The horizontal size of the page in mms.
 
float sizeY
 The vertical size of the page in mms.
 

Detailed Description

Contains the different page options for saving to pdf file.

Remarks
If you want to save the content of a window, the type of the file fileTypeID in API_FileSavePars should be set to APIFType_PdfFile. In case of 3D and Master Layout Archicad will export the floor plan.