Texture reference.
More...
#include <APIdefs_Attributes.h>
|
short | status |
| Texture status.
|
|
bool | missingPict |
| Picture is missing (output only)
|
|
double | xSize |
| X size of the picture in model space.
|
|
double | ySize |
| Y size of the picture in model space.
|
|
double | rotAng |
| Rotation angle in radians.
|
|
Int32 | irtxt |
| for internal use
|
|
GS::uchar_t | texName [API_UniLongNameLen] |
| The name of the texture file as UTF-8 encoded C string.
|
|
IO::Location * | fileLoc |
| Texture file location in the file system.
|
|
bool | withoutExtension |
| [in] Indicates that the extension was not appended to the texture name.
|
|