Archicad 28 C++ API
Loading...
Searching...
No Matches
API_WorkingUnitPrefs Struct Reference

The representation of the Preferences / Units tab page. More...

#include <APIdefs_Environment.h>

Public Attributes

API_LengthTypeID lengthUnit
 The type of the length measurement unit.
 
API_AreaTypeID areaUnit
 The type of the area measurement unit.
 
API_VolumeTypeID volumeUnit
 The type of the volume measurement unit.
 
API_AngleTypeID angleUnit
 The type of the angle measurement unit.
 
short roundInch
 1, 2, 4, 8, 16, 32, 64
 
short lenDecimals
 Number of decimals for length measurement unit. (0..4)
 
short areaDecimals
 Number of decimals for area measurement unit. (0..4)
 
short volumeDecimals
 Number of decimals for volume measurement unit. (0..4)
 
short angleDecimals
 Number of decimals for angle measurement unit. (0..4)
 
short angleAccuracy
 0..4
 

Detailed Description

The representation of the Preferences / Units tab page.

See also
ACAPI_ProjectSetting_GetPreferences, ACAPI_ProjectSetting_SetPreferences
Remarks
This structure is used by the ACAPI_ProjectSetting_GetPreferences function to get the settings of the unit preferences page.