Archicad 28 C++ API
Loading...
Searching...
No Matches
ACAPI::Impl::ObjectImpl Class Reference

ObjectImpl is the base class for all the implementation classes. More...

#include <ObjectImpl.hpp>

Inheritance diagram for ACAPI::Impl::ObjectImpl:
ACAPI::LicenseInfo::Impl::ProductVersionInfoImplBase

Public Member Functions

 ObjectImpl (const API_Token &token)
 Constructs an object of the ObjectImpl class.
 
const API_TokenGetToken () const
 You can get the token that's used by the implementation.
 

Protected Attributes

const API_Token token
 The token used by the implementation.
 

Detailed Description

ObjectImpl is the base class for all the implementation classes.

Since
Archicad 28