Archicad 28 C++ API
Loading...
Searching...
No Matches
ACAPI::v1::UniqueID Class Reference

A unique identifier for API objects. It contains the GUID of the element and the Token of the AddOn which instantiated the element. More...

#include <UniqueID.hpp>

Inheritance diagram for ACAPI::v1::UniqueID:
ACAPI::MEP::UniqueID ACAPI::MEP::Adapter::UniqueID

Public Member Functions

 UniqueID (const GS::Guid &, const API_Token &)
 Constructs a unique identifier with the given GUID and token.
 
const GS::Guid & GetGuid () const
 Returns the unique identifier of the element.
 
const API_TokenGetToken () const
 Returns the unique identifier of the AddOn which created this instance.
 
bool operator== (const UniqueID &) const
 Comparison operator.
 
bool operator!= (const UniqueID &) const
 Comparison operator.
 
bool operator< (const UniqueID &) const
 Comparison operator.
 

Detailed Description

A unique identifier for API objects. It contains the GUID of the element and the Token of the AddOn which instantiated the element.

Member Function Documentation

◆ GetGuid()

const GS::Guid & ACAPI::v1::UniqueID::GetGuid ( ) const

Returns the unique identifier of the element.

Returns
The unique identifier of the element.

◆ GetToken()

const API_Token & ACAPI::v1::UniqueID::GetToken ( ) const

Returns the unique identifier of the AddOn which created this instance.

Returns
The unique identifier of the AddOn which created this instance.

◆ operator!=()

bool ACAPI::v1::UniqueID::operator!= ( const UniqueID ) const

Comparison operator.

Returns
True if given object is not equal to this object.

◆ operator<()

bool ACAPI::v1::UniqueID::operator< ( const UniqueID ) const

Comparison operator.

Returns
True if given object is bigger than this object.

◆ operator==()

bool ACAPI::v1::UniqueID::operator== ( const UniqueID ) const

Comparison operator.

Returns
True if given object is equal to this object.