Archicad 28 C++ API
|
#include <APIdefs_Callback.h>
Public Member Functions | |
virtual GS::UniString | GetName () const override final |
virtual void | Dispatch (const API_IEventNotifier &eventNotifier) const override final |
It dispatches the event. | |
virtual void | OnUserChanged () const =0 |
Event handler for Graphisoft ID changes. | |
virtual GS::UniString | GetName () const =0 |
virtual void | Dispatch (const API_IEventNotifier &eventNotifier) const =0 |
It dispatches the event. | |
The base class you need to inherit from in case you want to handle Graphisoft ID change event.
|
inlinefinaloverridevirtual |
It dispatches the event.
eventNotifier | The occurrence of an event can be notified via this parameter. |
Implements API_IEventHandler.
|
inlinefinaloverridevirtual |
Implements API_IEventHandler.