Archicad 28 C++ API
Loading...
Searching...
No Matches
API_IEventHandler Class Referenceabstract

Defining an interface for all event handlers. More...

#include <APIdefs_Callback.h>

Inheritance diagram for API_IEventHandler:
ACAPI::API_IKeynoteFolderEventHandler ACAPI::API_IKeynoteItemEventHandler API_IAttributeEventHandler API_IAttributeFolderEventHandler API_IClassificationItemEventHandler API_IClassificationSystemEventHandler API_IEnableAllInfoDialogEventHandler API_IGraphisoftIDEventHandler API_IMarqueeEventHandler API_IPropertyDefinitionEventHandler API_IPropertyGroupEventHandler API_IWindowEventHandler

Public Member Functions

virtual GS::UniString GetName () const =0
 
virtual void Dispatch (const API_IEventNotifier &eventNotifier) const =0
 It dispatches the event.
 

Detailed Description

Defining an interface for all event handlers.

Since
Archicad 26

Member Function Documentation

◆ Dispatch()

◆ GetName()