Archicad 28 C++ API
|
#include <APIdefs_Callback.h>
Public Member Functions | |
virtual GS::UniString | GetName () const override final |
virtual void | Dispatch (const API_IEventNotifier &eventNotifier) const override final |
It dispatches the event. | |
virtual void | OnMarqueeChanged (const API_SelectionInfo &selectionInfo) const =0 |
Event handler for marquee changes. | |
virtual GS::UniString | GetName () const =0 |
virtual void | Dispatch (const API_IEventNotifier &eventNotifier) const =0 |
It dispatches the event. | |
The base class you need to inherit from in case you want to handle Marquee change event.
|
inlinefinaloverridevirtual |
It dispatches the event.
eventNotifier | The occurrence of an event can be notified via this parameter. |
Implements API_IEventHandler.
|
inlinefinaloverridevirtual |
Implements API_IEventHandler.
|
pure virtual |
Event handler for marquee changes.
selectionInfo | Information about the current selection. |