Archicad 27 C++ API
Loading...
Searching...
No Matches
API_SelectionInfo Struct Reference

Information about the current selection. More...

#include <APIdefs_Elements.h>

Public Attributes

API_SelTypeID typeID
 The type of the selection. It can be one of the marquee type or element type selection.
 
Int32 sel_nElem
 Number of selected elements.
 
Int32 sel_nElemEdit
 Number of the currently selected elements, which are editable.
 
bool multiStory
 The marquee selection is extended to all stories.
 
API_Region marquee
 The parameters of the marquee selection region.
 

Detailed Description

Information about the current selection.

Remarks
This structure is used to determine the type and the parameters of the current selection. You can retrieve this information with the ACAPI_Selection_Get function. To change the current marquee with ACAPI_Selection_SetMarquee, you should set the typeID, multiStory and marquee fields in the API_SelectionInfo parameter. In case of marquee-type selection don't forget to dispose the coords handle in the marquee region when you don't need it any more.

Member Data Documentation

◆ marquee

API_SelectionInfo::marquee

The parameters of the marquee selection region.