Archicad 27 C++ API
Loading...
Searching...
No Matches
API_Region Struct Reference

Polygonal or rectangular region of the model. More...

#include <APIdefs_Base.h>

Public Attributes

Int32 nCoords
 number of coordinates (in case of polygonal representation)
 
API_Coord ** coords
 the coordinate handle (in case of polygonal representation)
 
API_Box box
 the rectangle (in case rectangular representation)
 
double boxRotAngle
 the rotation angle (in case rectangular representation)
 

Detailed Description

Polygonal or rectangular region of the model.

Remarks
It is a closed polygon expressed in model coordinates. Special representation can be a (rotated) rectangle. In the case of polygonal representation the data structure follows the rules specified in API_Polygon.