Archicad 28 C++ API
Loading...
Searching...
No Matches
API_Box Struct Reference

Rectangular region of the model. More...

#include <APIdefs_Base.h>

Public Attributes

double xMin
 Minimum value of the x coordinate of the box.
 
double yMin
 Minimum value of the y coordinate of the box.
 
double xMax
 Maximum value of the x coordinate of the box.
 
double yMax
 Maximum value of the y coordinate of the box.
 

Detailed Description

Rectangular region of the model.

Remarks
It is a rectangle in model coordinates. Always expressed in meters, if no other instructions in the corresponding documentation. For the integer type representation refer to the API_Rect structure or to the ACAPI_View_CoordToPoint and ACAPI_View_CoordToPoint functions for the conversion algorithms.