Archicad 28 C++ API
Loading...
Searching...
No Matches
API_Rect Struct Reference

Rectangle in pixel coordinates. More...

#include <APIdefs_Base.h>

Public Attributes

short top
 top pixel (vertical) of the rectangle
 
short left
 left pixel (horizontal) of the rectangle
 
short bottom
 bottom pixel (vertical) of the rectangle
 
short right
 right pixel (horizontal) of the rectangle
 

Detailed Description

Rectangle in pixel coordinates.

Remarks
An integer type representation of an API_Box. Expressed in the local coordinates of the window, based on pixels from the top/left corner. Refer to the ACAPI_View_CoordToPoint and ACAPI_View_CoordToPoint conversion functions for further details.