Archicad 28 C++ API
Loading...
Searching...
No Matches
API_IEnableAllInfoDialogEventHandler Class Reference

#include <APIdefs_Callback.h>

Inheritance diagram for API_IEnableAllInfoDialogEventHandler:
API_IEventHandler API_IDialogEventHandler

Public Member Functions

virtual GS::UniString GetName () const override final
 
virtual void Dispatch (const API_IEventNotifier &eventNotifier) const override final
 It dispatches the event.
 
virtual GS::UniString GetName () const =0
 
virtual void Dispatch (const API_IEventNotifier &eventNotifier) const =0
 It dispatches the event.
 
- Public Member Functions inherited from API_IDialogEventHandler
virtual void EnableAllInfoDialog () const =0
 Event handler in case of enabling all informational messages in the Work Environment.
 

Detailed Description

The base class you need to inherit from in case you want to handle Info Dialog change event.

Since
Archicad 26

Member Function Documentation

◆ Dispatch()

virtual void API_IEnableAllInfoDialogEventHandler::Dispatch ( const API_IEventNotifier eventNotifier) const
inlinefinaloverridevirtual

It dispatches the event.

Parameters
eventNotifierThe occurrence of an event can be notified via this parameter.

Implements API_IEventHandler.

◆ GetName()

virtual GS::UniString API_IEnableAllInfoDialogEventHandler::GetName ( ) const
inlinefinaloverridevirtual
Returns
Human readable name of the event handler.

Implements API_IEventHandler.