Archicad 28 C++ API
|
Defining an interface for Attribute Folder event handlers. More...
#include <APIdefs_Callback.h>
Public Member Functions | |
virtual GS::UniString | GetName () const override final |
virtual void | Dispatch (const API_IEventNotifier &eventNotifier) const override final |
It dispatches the event. | |
virtual GS::UniString | GetName () const =0 |
virtual void | Dispatch (const API_IEventNotifier &eventNotifier) const =0 |
It dispatches the event. | |
Public Member Functions inherited from API_IObjectEventHandler | |
virtual void | OnCreated (const GS::HashSet< API_Guid > &) const |
Event handler for object creation events. | |
virtual void | OnModified (const GS::HashSet< API_Guid > &) const |
Event handler for object modification events. | |
virtual void | OnDeleted (const GS::HashSet< API_Guid > &) const |
Event handler for object deletion events. | |
Defining an interface for Attribute Folder event handlers.
|
inlinefinaloverridevirtual |
It dispatches the event.
eventNotifier | The occurrence of an event can be notified via this parameter. |
Implements API_IEventHandler.
|
inlinefinaloverridevirtual |
Implements API_IEventHandler.