Archicad 28 C++ API
Loading...
Searching...
No Matches
API_IObjectEventHandler Class Reference

Defining an interface for Object event handlers. More...

#include <APIdefs_Callback.h>

Inheritance diagram for API_IObjectEventHandler:
ACAPI::API_IKeynoteFolderEventHandler ACAPI::API_IKeynoteItemEventHandler API_IAttributeEventHandler API_IAttributeFolderEventHandler API_IClassificationItemEventHandler API_IClassificationSystemEventHandler API_IPropertyDefinitionEventHandler API_IPropertyGroupEventHandler

Public Member Functions

virtual void OnCreated (const GS::HashSet< API_Guid > &) const
 Event handler for object creation events.
 
virtual void OnModified (const GS::HashSet< API_Guid > &) const
 Event handler for object modification events.
 
virtual void OnDeleted (const GS::HashSet< API_Guid > &) const
 Event handler for object deletion events.
 

Detailed Description

Defining an interface for Object event handlers.

Since
Archicad 26