Archicad 28 C++ API
Loading...
Searching...
No Matches
IFCAPI::v1::HookManager Member List
This is the complete list of members for
IFCAPI::v1::HookManager
, including all inherited members.
AssignmentsHookFunction
typedef
IFCAPI::v1::HookManager
AttributeHookFunction
typedef
IFCAPI::v1::HookManager
ClassificationReferenceHookFunction
typedef
IFCAPI::v1::HookManager
GetHookManager
IFCAPI::v1::HookManager
friend
PropertyHookFunction
typedef
IFCAPI::v1::HookManager
RegisterAssignmentsHook
(const IFCAPI::v1::HookManager::AssignmentsHookFunction &callback)
IFCAPI::v1::HookManager
RegisterAttributeHook
(const IFCAPI::v1::HookManager::AttributeHookFunction &callback)
IFCAPI::v1::HookManager
RegisterClassificationReferenceHook
(const IFCAPI::v1::HookManager::ClassificationReferenceHookFunction &callback)
IFCAPI::v1::HookManager
RegisterPropertyHook
(const IFCAPI::v1::HookManager::PropertyHookFunction &callback)
IFCAPI::v1::HookManager
RegisterTypeObjectAttributeHook
(const IFCAPI::v1::HookManager::AttributeHookFunction &callback)
IFCAPI::v1::HookManager
RegisterTypeObjectClassificationReferenceHook
(const IFCAPI::v1::HookManager::ClassificationReferenceHookFunction &callback)
IFCAPI::v1::HookManager
RegisterTypeObjectPropertyHook
(const IFCAPI::v1::HookManager::PropertyHookFunction &callback)
IFCAPI::v1::HookManager
UnregisterAssignmentsHook
()
IFCAPI::v1::HookManager
UnregisterAttributeHook
()
IFCAPI::v1::HookManager
UnregisterClassificationReferenceHook
()
IFCAPI::v1::HookManager
UnregisterPropertyHook
()
IFCAPI::v1::HookManager
UnregisterTypeObjectAttributeHook
()
IFCAPI::v1::HookManager
UnregisterTypeObjectClassificationReferenceHook
()
IFCAPI::v1::HookManager
UnregisterTypeObjectPropertyHook
()
IFCAPI::v1::HookManager
~HookManager
() (defined in
IFCAPI::v1::HookManager
)
IFCAPI::v1::HookManager