Archicad 28 C++ API
Loading...
Searching...
No Matches
IFCAPI::v1::HookManager Class Reference

To register an add-on for IFC hook callbacks, where one can provide their own data to the IFC export. More...

#include <IFCHookManager.hpp>

Inheritance diagram for IFCAPI::v1::HookManager:
ACAPI::v1::Object

Public Types

using PropertyHookFunction = std::function< void(const IFCAPI::ObjectID &, std::vector< IFCAPI::Property > &)>
 Function definition to add generated IFC properties to IFC objects.
 
using AttributeHookFunction = std::function< void(const IFCAPI::ObjectID &, std::vector< IFCAPI::Attribute > &)>
 Function definition to fill IFC attributes with generated values in IFC objects.
 
using ClassificationReferenceHookFunction = std::function< void(const IFCAPI::ObjectID &, std::vector< IFCAPI::ClassificationReference > &)>
 Function definition to add generated IFC classification references to IFC objects.
 
using AssignmentsHookFunction = std::function< void(IFCAPI::v1::HookAssignments &)>
 Function definition to set up a generated IFC assignment structure for IFC export.
 

Public Member Functions

ACAPI::Result< void > RegisterPropertyHook (const IFCAPI::v1::HookManager::PropertyHookFunction &callback)
 Register for the IFC property export hook.
 
ACAPI::Result< void > UnregisterPropertyHook ()
 Unregister from the IFC property export hook.
 
ACAPI::Result< void > RegisterAttributeHook (const IFCAPI::v1::HookManager::AttributeHookFunction &callback)
 Register for the IFC attribute export hook.
 
ACAPI::Result< void > UnregisterAttributeHook ()
 Unregister from the IFC attribute export hook.
 
ACAPI::Result< void > RegisterClassificationReferenceHook (const IFCAPI::v1::HookManager::ClassificationReferenceHookFunction &callback)
 Register for the IFC classification reference export hook.
 
ACAPI::Result< void > UnregisterClassificationReferenceHook ()
 Unregister from the IFC classification reference export hook.
 
ACAPI::Result< void > RegisterTypeObjectPropertyHook (const IFCAPI::v1::HookManager::PropertyHookFunction &callback)
 Register for the IFC type objects' property export hook.
 
ACAPI::Result< void > UnregisterTypeObjectPropertyHook ()
 Unregister from the IFC type objects' property export hook.
 
ACAPI::Result< void > RegisterTypeObjectAttributeHook (const IFCAPI::v1::HookManager::AttributeHookFunction &callback)
 Register for the IFC type objects' attribute export hook.
 
ACAPI::Result< void > UnregisterTypeObjectAttributeHook ()
 Unregister from the IFC type objects' attribute export hook.
 
ACAPI::Result< void > RegisterTypeObjectClassificationReferenceHook (const IFCAPI::v1::HookManager::ClassificationReferenceHookFunction &callback)
 Register for the IFC type objects' classification reference export hook.
 
ACAPI::Result< void > UnregisterTypeObjectClassificationReferenceHook ()
 Unregister from the IFC type objects' classification reference export hook.
 
ACAPI::Result< void > RegisterAssignmentsHook (const IFCAPI::v1::HookManager::AssignmentsHookFunction &callback)
 Register for the IFC assignments export hook.
 
ACAPI::Result< void > UnregisterAssignmentsHook ()
 Unregister from the IFC assignments export hook.
 

Friends

HookManager GetHookManager ()
 Get HookManager to register an add-on for IFC hook callbacks.
 

Detailed Description

To register an add-on for IFC hook callbacks, where one can provide their own data to the IFC export.

Since
Archicad 28
Remarks
See IFCHook_Test.cpp for a complete example.

Friends And Related Symbol Documentation

◆ GetHookManager

HookManager GetHookManager ( )
friend

Get HookManager to register an add-on for IFC hook callbacks.

Since
Archicad 28
Returns
The HookManager
Remarks
See IFCHook_Test.cpp for a complete example.