Archicad 28 C++ API
Loading...
Searching...
No Matches
IFCAPI::v1::HookAssignments Class Referencefinal

Class to set up an assignment structure for the assignments export hook. More...

#include <IFCHookAssignments.hpp>

Inheritance diagram for IFCAPI::v1::HookAssignments:
ACAPI::v1::Object

Public Member Functions

ACAPI::Result< IFCAPI::ObjectIDCreateIfcGroup (const API_Guid &guid, const IFCType &ifcType, const std::optional< GS::UniString > &name, bool addAsRoot)
 Add an IFC Group definition to the assignment hook structure.
 
ACAPI::Result< IFCAPI::ObjectIDGetIfcRelAssignsToGroup (const IFCAPI::ObjectID groupObjectID) const
 Get the IFC RelAssignsToGroup object of the passed group object.
 
ACAPI::Result< IFCAPI::ObjectIDGetIfcRelServicesBuildings (const IFCAPI::ObjectID systemObjectID) const
 Get the IFC RelServicesBuildings object of the passed system object.
 
ACAPI::Result< void > AssignObjects (const IFCAPI::ObjectID groupID, const std::vector< IFCAPI::ObjectID > &assignedObjectIDs)
 Assign objects to the passed group object.
 
ACAPI::Result< void > ServiceBuildings (const IFCAPI::ObjectID systemID, const std::vector< IFCAPI::ObjectID > &servicedObjectIDs)
 Set serviced spatial element objects to the passed system object.
 
- Public Member Functions inherited from ACAPI::v1::Object
 Object (std::shared_ptr< Impl::ObjectImpl > impl)
 Constructs a new object.
 
const API_TokenGetToken () const
 Get the token for this object.
 

Friends

class HookDataProvider
 

Additional Inherited Members

- Protected Member Functions inherited from ACAPI::v1::Object
 ~Object ()
 Default destructor.
 
- Protected Attributes inherited from ACAPI::v1::Object
std::shared_ptr< Impl::ObjectImplmImpl
 Impl object given by constructor.
 

Detailed Description

Class to set up an assignment structure for the assignments export hook.

Since
Archicad 28
Remarks
See IFCHook_Test.cpp for a complete example.