Archicad 28 C++ API
Loading...
Searching...
No Matches
ACAPI::v1::Object Class Reference

A base class for all ACAPI objects. Purely technical. More...

#include <Object.hpp>

Inheritance diagram for ACAPI::v1::Object:
ACAPI::Cutaway::v1::CuttingPlane ACAPI::DesignOptions::v1::DesignOptionCombination ACAPI::DesignOptions::v1::DesignOptionCombinationViewSettings ACAPI::DesignOptions::v1::DesignOptionManager ACAPI::Keynote::v1::KeynoteFolder ACAPI::Keynote::v1::KeynoteItem ACAPI::Keynote::v1::KeynoteManager ACAPI::Library::v1::GSMObject ACAPI::Library::v1::LibPart ACAPI::Library::v1::Library ACAPI::Library::v1::LibraryManager ACAPI::Library::v1::LibraryTreePath ACAPI::LicenseInfo::v1::LicenseInfoManager ACAPI::LicenseInfo::v1::ProductVersionInfo ACAPI::MEP::v1::AccessoryUIManager ACAPI::MEP::v1::BendUIManager ACAPI::MEP::v1::BranchUIManager ACAPI::MEP::v1::CableCarrierSegmentPreferenceTable ACAPI::MEP::v1::DistributionSystem ACAPI::MEP::v1::DistributionSystemsGraph ACAPI::MEP::v1::DistributionSystemsGraphTreeNode ACAPI::MEP::v1::DuctBranchPreferenceTable ACAPI::MEP::v1::DuctCircularSegmentPreferenceTable ACAPI::MEP::v1::DuctElbowPreferenceTable ACAPI::MEP::v1::DuctRectangularSegmentPreferenceTable ACAPI::MEP::v1::ElementUIManager ACAPI::MEP::v1::EquipmentUIManager ACAPI::MEP::v1::FittingUIManager ACAPI::MEP::v1::FlexibleSegmentUIManager ACAPI::MEP::v1::GraphCalculationInterface ACAPI::MEP::v1::PipeBranchPreferenceTable ACAPI::MEP::v1::PipeElbowPreferenceTable ACAPI::MEP::v1::PipeSegmentPreferenceTable ACAPI::MEP::v1::PortBase ACAPI::MEP::v1::PortDefaultBase ACAPI::MEP::v1::PreferenceTableContainerBase ACAPI::MEP::v1::ReferenceSetBase ACAPI::MEP::v1::RigidSegmentUIManager ACAPI::MEP::v1::RoutingElementUIManager ACAPI::MEP::v1::RoutingNodeUIManager ACAPI::MEP::v1::RoutingSegmentUIManager ACAPI::MEP::v1::TakeOffUIManager ACAPI::MEP::v1::TerminalUIManager ACAPI::MEP::v1::TransitionUIManager ACAPI::ModelViews::v1::View ACAPI::Tracking::v1::TrackerManager ACAPI::v1::ElementBase ACAPI::v1::ElementDefault ACAPI::v1::GSID ACAPI::v1::InputHandler ACAPI::v1::ZoneBoundary ACAPI::v1::ZoneBoundaryQuery ACAPI::v1::ZoneLabelingSettings IFCAPI::v1::Assignments IFCAPI::v1::Attribute IFCAPI::v1::Classification IFCAPI::v1::ClassificationReference IFCAPI::v1::HookAssignments IFCAPI::v1::HookManager IFCAPI::v1::ObjectAccessor IFCAPI::v1::ObjectID IFCAPI::v1::Property IFCAPI::v1::PropertyAccessor IFCAPI::v1::PropertyBoundedValue IFCAPI::v1::PropertyBuilder IFCAPI::v1::PropertyEnumeratedValue IFCAPI::v1::PropertyListValue IFCAPI::v1::PropertySingleValue IFCAPI::v1::PropertyTableValue IFCAPI::v1::Value

Public Member Functions

 Object (std::shared_ptr< Impl::ObjectImpl > impl)
 Constructs a new object.
 
const API_TokenGetToken () const
 Get the token for this object.
 

Protected Member Functions

 ~Object ()
 Default destructor.
 

Protected Attributes

std::shared_ptr< Impl::ObjectImplmImpl
 Impl object given by constructor.
 

Friends

class Impl::UsageLogger
 
template<class T >
class Impl::ImplAccessor
 

Detailed Description

A base class for all ACAPI objects. Purely technical.

Constructor & Destructor Documentation

◆ Object()

ACAPI::v1::Object::Object ( std::shared_ptr< Impl::ObjectImpl impl)

Constructs a new object.

Parameters
implImpl instance of the object.

Member Function Documentation

◆ GetToken()

const API_Token & ACAPI::v1::Object::GetToken ( ) const

Get the token for this object.

Returns
The token for this object.