Archicad 28 C++ API
Loading...
Searching...
No Matches
IFCAPI::v1::Property Class Referencefinal

Represents an IfcProperty. More...

#include <IFCProperty.hpp>

Inheritance diagram for IFCAPI::v1::Property:
ACAPI::v1::Object

Public Member Functions

GS::UniString GetPropertySetName () const
 Name of the container IfcPropertySet.
 
GS::UniString GetName () const
 Name of the IfcProperty.
 
PropertyByType GetTyped () const
 Instance of the specific property type.
 
- Public Member Functions inherited from ACAPI::v1::Object
 Object (std::shared_ptr< Impl::ObjectImpl > impl)
 Constructs a new object.
 
const API_TokenGetToken () const
 Get the token for this object.
 

Friends

class PropertyAccessor
 
class PropertyBuilder
 

Additional Inherited Members

- Protected Member Functions inherited from ACAPI::v1::Object
 ~Object ()
 Default destructor.
 
- Protected Attributes inherited from ACAPI::v1::Object
std::shared_ptr< Impl::ObjectImplmImpl
 Impl object given by constructor.
 

Detailed Description

Represents an IfcProperty.

Since
Archicad 28