Archicad 28 C++ API
Loading...
Searching...
No Matches
IFCAPI::v1::ClassificationReference Class Referencefinal

Represents an IfcClassificationReference. More...

#include <IFCClassificationReference.hpp>

Inheritance diagram for IFCAPI::v1::ClassificationReference:
ACAPI::v1::Object

Public Member Functions

std::optional< GS::UniString > GetLocation () const
 Location of the IfcClassificationReference.
 
std::optional< GS::UniString > GetName () const
 Name of the IfcClassificationReference.
 
std::optional< GS::UniString > GetIdentification () const
 Identification of the IfcClassificationReference.
 
IFCAPI::Classification GetReferencedSource () const
 ReferencedSource of the IfcClassificationReference.
 
GS::UniString GetIfcRelAssociatesClassificationName () const
 Name of the IfcRelAssociatesClassification.
 
- Public Member Functions inherited from ACAPI::v1::Object
 Object (std::shared_ptr< Impl::ObjectImpl > impl)
 Constructs a new object.
 
const API_TokenGetToken () const
 Get the token for this object.
 

Friends

class PropertyAccessor
 
class PropertyBuilder
 

Additional Inherited Members

- Protected Member Functions inherited from ACAPI::v1::Object
 ~Object ()
 Default destructor.
 
- Protected Attributes inherited from ACAPI::v1::Object
std::shared_ptr< Impl::ObjectImplmImpl
 Impl object given by constructor.
 

Detailed Description

Represents an IfcClassificationReference.

Since
Archicad 28