Archicad 28 C++ API
Loading...
Searching...
No Matches
IFCAPI::v1::Classification Class Referencefinal

Represents an IfcClassification. More...

#include <IFCClassificationReference.hpp>

Inheritance diagram for IFCAPI::v1::Classification:
ACAPI::v1::Object

Public Member Functions

GS::UniString GetName () const
 Name of the IfcClassification.
 
std::optional< GS::UniString > GetSource () const
 Source of the IfcClassification.
 
std::optional< GS::UniString > GetEdition () const
 Edition of the IfcClassification.
 
std::optional< GS::UniString > GetEditionDate () const
 EditionDate of the IfcClassification.
 
std::optional< GS::UniString > GetDescription () const
 Description of the IfcClassification.
 
std::optional< GS::UniString > GetLocation () const
 Location of the IfcClassification.
 
- Public Member Functions inherited from ACAPI::v1::Object
 Object (std::shared_ptr< Impl::ObjectImpl > impl)
 Constructs a new object.
 
const API_TokenGetToken () const
 Get the token for this object.
 

Friends

class PropertyBuilder
 
class ClassificationReference
 

Additional Inherited Members

- Protected Member Functions inherited from ACAPI::v1::Object
 ~Object ()
 Default destructor.
 
- Protected Attributes inherited from ACAPI::v1::Object
std::shared_ptr< Impl::ObjectImplmImpl
 Impl object given by constructor.
 

Detailed Description

Represents an IfcClassification.

Since
Archicad 28