Archicad 28 C++ API
Loading...
Searching...
No Matches
IFCAPI::v1::Attribute Class Referencefinal

Represents an IFC Attribute. More...

#include <IFCAttribute.hpp>

Inheritance diagram for IFCAPI::v1::Attribute:
ACAPI::v1::Object

Public Member Functions

GS::UniString GetName () const
 Name of the Attribute.
 
std::optional< GS::UniString > GetValue () const
 Value of the Attribute.
 
IFCAPI::IFCType GetValueType () const
 Value type of the Attribute.
 
- Public Member Functions inherited from ACAPI::v1::Object
 Object (std::shared_ptr< Impl::ObjectImpl > impl)
 Constructs a new object.
 
const API_TokenGetToken () const
 Get the token for this object.
 

Friends

class PropertyAccessor
 
class PropertyBuilder
 

Additional Inherited Members

- Protected Member Functions inherited from ACAPI::v1::Object
 ~Object ()
 Default destructor.
 
- Protected Attributes inherited from ACAPI::v1::Object
std::shared_ptr< Impl::ObjectImplmImpl
 Impl object given by constructor.
 

Detailed Description

Represents an IFC Attribute.

Since
Archicad 28