Archicad 28 C++ API
Loading...
Searching...
No Matches
IFCAPI::v1::Value Class Referencefinal

Represent an IFC value. More...

#include <IFCValue.hpp>

Inheritance diagram for IFCAPI::v1::Value:
ACAPI::v1::Object

Public Member Functions

IFCAPI::IFCType GetType () const
 The type of the Value (For example: IfcLabel, IfcPositiveLengthMeasure, ...)
 
IFCAPI::AnyValue GetAnyValue () const
 The value.
 
- Public Member Functions inherited from ACAPI::v1::Object
 Object (std::shared_ptr< Impl::ObjectImpl > impl)
 Constructs a new object.
 
const API_TokenGetToken () const
 Get the token for this object.
 

Friends

class PropertySingleValue
 
class PropertyListValue
 
class PropertyBoundedValue
 
class PropertyEnumeratedValue
 
class PropertyTableValue
 
class PropertyBuilder
 

Additional Inherited Members

- Protected Member Functions inherited from ACAPI::v1::Object
 ~Object ()
 Default destructor.
 
- Protected Attributes inherited from ACAPI::v1::Object
std::shared_ptr< Impl::ObjectImplmImpl
 Impl object given by constructor.
 

Detailed Description

Represent an IFC value.

Since
Archicad 28