Archicad 27 C++ API
Loading...
Searching...
No Matches
Error Codes

Error Codes

The special API error codes are listed on this page; they can be found in the APIdefs_ErrorCodes.h header.
General descriptions are given, with the circumstances they can be returned by an API function.

Code Value Hex Description
APIERR_GENERAL -2130313215 81060001 General error code.
APIERR_MEMFULL -2130313214 81060002 Insufficient memory.
APIERR_CANCEL -2130313213 81060003 The operation has been canceled by the user, in case of a long process.
APIERR_BADID -2130313115 81060065 The passed identifier is not a valid one, or valid, but not proper for the given operation.
APIERR_BADINDEX -2130313114 81060066 The passed index is out of range.
APIERR_BADNAME -2130313113 81060067 The passed name is not proper or not found in the existing list.
APIERR_BADPARS -2130313112 81060068 The passed parameters are inconsistent.
APIERR_BADPOLY -2130313111 81060069 The passed polygon cannot be interpreted.
APIERR_BADDATABASE -2130313110 8106006A The command cannot be executed on the current database.
APIERR_BADWINDOW -2130313109 8106006B The command cannot be executed while the current window is active.
APIERR_BADKEYCODE -2130313108 8106006C The key code cannot be found in the listing database.
APIERR_BADPLATFORMSIGN -2130313107 8106006D The passed platform sign is not valid. See ACAPI_ModulData_Store.
APIERR_BADPLANE -2130313106 8106006E The plane equation is incorrect.
APIERR_BADUSERID -2130313105 8106006F The passed user ID (TeamWork client) is not valid.
APIERR_BADVALUE -2130313104 81060070 The passed autotext value is not valid. See ACAPI_AutoText_SetAnAutoText.
APIERR_BADELEMENTTYPE -2130313103 81060071 The function cannot be applied to the passed element type. See ACAPI_Element_Trim_Elements.
APIERR_IRREGULARPOLY -2130313102 81060072 The passed polygon or polyline is irregular. See API_RegularizedPoly.
APIERR_BADEXPRESSION -2130313101 81060073 The passed expression string is syntactically incorrect.
APIERR_BADGUID -2130313100 81060074 The passed guid is invalid or valid, but not proper for the given operation.
APIERR_BADTOKEN -2130313099 81060075 The passed token is invalid. See ACAPI_GetToken.
APIERR_NO3D -2130313015 810600C9 There is no 3D information assigned to the passed element.
APIERR_NOMORE -2130313014 810600CA No more database items can be returned.
APIERR_NOPLAN -2130313013 810600CB There is no open project. The operation cannot be executed without an open project.
APIERR_NOLIB -2130313012 810600CC No library was loaded. The operation cannot be executed without a loaded library. Can be returned by ACAPI_LibraryPart_Create.
APIERR_NOLIBSECT -2130313011 810600CD The requested LibPart section is not found.
APIERR_NOSEL -2130313010 810600CE No selection. The operation cannot be executed without any element selected.
APIERR_NOTEDITABLE -2130313009 810600CF The referenced element is not editable.
APIERR_NOTSUBTYPEOF -2130313008 810600D0 The specified first library part unique ID does not refer to a subtype of the second unique ID. See ACAPI_LibraryPart_CheckLibPartSubtypeOf.
APIERR_NOTEQUALMAIN -2130313007 810600D1 The main GUID parts of the specified two library part unique IDs are not equal. See ACAPI_LibraryPart_CompareLibPartUnIds.
APIERR_NOTEQUALREVISION -2130313006 810600D2 The main GUID parts of the specified two library part unique IDs are equal but their revision IDs differ. See ACAPI_LibraryPart_CompareLibPartUnIds.
APIERR_NOTEAMWORKPROJECT -2130313005 810600D3 There is no open project, or not in Teamwork mode.
APIERR_NOUSERDATA -2130312996 810600DC Attempt to get user data assigned to an element, but there isn't any.
APIERR_MOREUSER -2130312995 810600DD The user data cannot be assigned to the element, since there is no free storage block avaliable.
APIERR_LINKEXIST -2130312994 810600DE The link already exists.
APIERR_LINKNOTEXIST -2130312993 810600DF The link doesn't exist.
APIERR_WINDEXIST -2130312992 810600E0 The window to be opened already exists.
APIERR_WINDNOTEXIST -2130312991 810600E1 The referenced window does not exist.
APIERR_UNDOEMPTY -2130312990 810600E2 No undoable entry has got into the opened undo operation.
APIERR_REFERENCEEXIST -2130312989 810600E3 The reference already exists.
APIERR_NAMEALREADYUSED -2130312988 810600E4 The resource must have a unique name but the specified one is already taken.
APIERR_ATTREXIST -2130312915 8106012D The attribute already exists.
APIERR_DELETED -2130312914 8106012E Reference to a deleted, purged or non-existent database item.
APIERR_LOCKEDLAY -2130312913 8106012F The referenced layer is locked.
APIERR_HIDDENLAY -2130312912 81060130 The referenced layer is hidden.
APIERR_INVALFLOOR -2130312911 81060131 The passed floor index is out of range.
APIERR_NOTMINE -2130312910 81060132 The database item is not in the user's workspace.
APIERR_NOACCESSRIGHT -2130312909 81060133 Can't access / create / modify / delete an item in a teamwork server.
APIERR_BADPROPERTY -2130312908 81060134 The property for the passed element or attribute is not available.
APIERR_BADCLASSIFICATION -2130312907 81060135 Can't set the classification for the passed element or attribute.
APIERR_NOTEXISTINGLAYER -2130312906 81060136 Given layer parameter index is not an existing one.
APIERR_NOCURRATTRSET -2130312905 81060137 No current attributeset.
APIERR_MODULNOTINSTALLED -2130312815 81060191 The referenced add-on is not installed. For more details see the Communication Manager.
APIERR_MODULCMDMINE -2130312814 81060192 The target add-on is the caller add-on. For more details see the Communication Manager.
APIERR_MODULCMDNOTSUPPORTED -2130312813 81060193 The referenced command is not supported by the target add-on. For more details see the Communication Manager.
APIERR_MODULCMDVERSNOTSUPPORTED -2130312812 81060194 The requested command version is newer than the version of the command that the target add-on can support. For more details see the Communication Manager.
APIERR_NOMODULEDATA -2130312811 81060195 No custom data section is saved into the project file identified by the add-on's unique ID. See ACAPI_ModulData_GetInfo.
APIERR_DEPRECATEDCALL -2130312810 81060196 The command (for this element type) is implemented on the C++ API in ArchicadAPI module and it is no longer available via the Old API. The function where it occured can be called for compatibility reasons but it takes no effect. For further information you can search the corresponding functionality in the API Documentation.
APIERR_PAROVERLAP -2130312715 810601F5 Two or more paragraphs are overlapped. The end offset of one is greater than the beginner offset of the next one.
APIERR_PARMISSING -2130312714 810601F6 Number of paragraphs - the size of paragraphs handle - is zero.
APIERR_PAROVERFLOW -2130312713 810601F7 Paragraph end offset is run over the content length.
APIERR_PARIMPLICIT -2130312712 810601F8 The content string contains line end character (CR) at invalid position (inside the paragraph range).
APIERR_RUNOVERLAP -2130312706 810601FE Two or more runs are overlapped. The end offset of one is greater than the beginner offset of the next one.
APIERR_RUNMISSING -2130312705 810601FF Number of runs - the size of run pointer - is zero.
APIERR_RUNOVERFLOW -2130312704 81060200 Run end offset is run over the content length.
APIERR_RUNIMPLICIT -2130312703 81060201 The beginner offset of one is greater than the end offset of the previous one.
APIERR_RUNPROTECTED -2130312702 81060202 Attempted to overwrite a protected text run (not used yet).
APIERR_EOLOVERLAP -2130312696 81060208 The EOL array is not a monotonous ascendant sequence.
APIERR_TABOVERLAP -2130312686 81060212 The tabulator array is not a monotonous ascendant sequence.
APIERR_NOTINIT -2130312315 81060385 The command needs initialization by an other API call.
APIERR_NESTING -2130312314 81060386 The API function is not reentrant. Nesting occurred.

| APIERR_NOTSUPPORTED | -2130312313 | 81060387 | The command is not supported by the server application. It is not environment dependent. The server application cannot execute the command generally.| APIERR_REFUSEDCMD | -2130312312 | 81060388 | The passed identifier is not subject to the operation. | APIERR_REFUSEDCMD | -2130312312 | 81060388 | The passed identifier is not subject to the operation. | APIERR_REFUSEDPAR | -2130312311 | 81060389 | The command cannot be executed with the passed parameters. | APIERR_READONLY | -2130312310 | 8106038A | The specified location is read-only. Can be returned by ACAPI_LibraryPart_Create. | APIERR_SERVICEFAILED | -2130312309 | 8106038B | The invoked Teamwork service has failed. | APIERR_COMMANDFAILED | -2130312308 | 8106038C | The invoked undoable command threw an exception. Can be returned by ACAPI_CallUndoableCommand. | APIERR_NEEDSUNDOSCOPE | -2130312307 | 8106038D | The called command should be encapsulated in a ACAPI_CallUndoableCommand scope. | APIERR_UNDOSCOPEMISUSE | -2130312306 | 8106038E | The called command shouldn't be encapsulated in a ACAPI_CallUndoableCommand scope. | APIERR_MISSINGCODE | -2130312215 | 810603E9 | The function is not implemented yet. | APIERR_MISSINGDEF | -2130312214 | 810603EA | The originating library part file is missing. The document name is still filled.