Archicad 28 C++ API
Loading...
Searching...
No Matches
API_3DWindowInfo Struct Reference

3D Window setting parameters. More...

#include <APIdefs_Environment.h>

Public Attributes

bool setWindowSize
 Resize the 3D window according to the hSize and vSize fields.
 
short hSize
 Horizontal size of the 3D window in pixels.
 
short vSize
 Vertical size of the 3D window in pixels.
 
bool setZoom
 Modify the projection zoom data according to the zoomScaleX, zoomScaleY, zoomDispX and zoomDispY fields.
 
double zoomScaleX
 Horizontal scale factor of the projection (ignored if setZoom is false)
 
double zoomScaleY
 Vertical scale factor of the projection (ignored if setZoom is false)
 
double zoomDispX
 Horizontal offset of the projection (ignored if setZoom is false)
 
double zoomDispY
 Vertical offset of the projection (ignored if setZoom is false)
 

Detailed Description

3D Window setting parameters.

Remarks
The API_3DWindowInfo structure is used by the ACAPI_View_Get3DWindowSets and the ACAPI_View_Change3DWindowSets environment functions.  With API ver. 21, the parameters and functionality regarding 3D drawing options and colors was moved to the API_3DStyle structure and related functions.