Archicad 28 C++ API
Loading...
Searching...
No Matches
API_AddonObject Struct Reference

Control information of a custom data stored into the project database. More...

#include <APIdefs_Callback.h>

Public Attributes

API_Guid id
 The GUID of the AddOnObject.
 
GS::UniString * name
 The name of the AddOnObject.
 
GSHandle data
 User specified data (cannot be nullptr).
 
API_AddonObjectType type
 Whether the AddOnObject is general (non-unique) or unique.
 

Detailed Description

Control information of a custom data stored into the project database.

Remarks
This structure is used by the AddOnObject Manager functions, for further details refer to these sections.