Archicad 28 C++ API
Loading...
Searching...
No Matches
API_AnalyticalLoadCase Struct Reference

Describes a Structural Analytical Load Case. More...

#include <APIdefs_AnalyticalModel.h>

Public Attributes

GS::UniString name
 Name of the load case.
 
GS::UniString description
 Description of the load case.
 
API_AnalyticalLoadCaseActionType actionType
 Action type of the load case.
 
API_Guid loadGroupGuid
 A unique identifier of the load group which contains the represented load case.
 
API_AnalyticalLoadCaseLoadType loadType
 Load type of the load case.
 
GS::Optional< API_AnalyticalLoadCaseDurationduration
 Duration of the load case.
 
API_Guid loadCaseGuid
 A unique identifier of the represented load case.
 

Detailed Description

Describes a Structural Analytical Load Case.

Since
Archicad 25