Archicad 27 C++ API
Loading...
Searching...
No Matches
API_Base Struct Reference

The base of a non-static linear, angle or radial dimension element. More...

#include <APIdefs_Elements.h>

Public Attributes

API_ElemType type
 The type of the base element.
 
bool line
 True in case of APINeig_WallOn, APINeig_WallPlOn, APINeig_BeamOn, APINeig_CeilOn, APINeig_RoofOn, APINeig_MeshOn, APINeig_HatchOn, APINeig_LineOn, APINeig_ArcOn, APINeig_SplineOn.
 
char special
 True in case of APINeig_WallPl, APINeig_WallPlOn, APINeig_BeamHole, APINeig_WindHole, APINeig_DoorHole, APINeig_MeshRidge, APINeig_MeshRidgeOn.
 
Int32 inIndex
 InIndex of the base element's node (see API_Neig).
 
API_Guid guid
 The unique identifier of the base element.
 
UInt32 node_id
 Polygon vertex id (from the API_ElementMemo of the elements which have a polygon).
 
short node_status
 For internal use (reserved for section dim).
 
short node_typ
 For internal use (reserved for section dim).
 

Detailed Description

The base of a non-static linear, angle or radial dimension element.

Since
Archicad 26
Remarks
From version 26 the type of the typeID member was changed into API_ElemType.