Archicad 28 C++ API
Toggle main menu visibility
Main Page
Introductory material
General API Development Kit 28
API White Paper
API Compatibility
License Agreement
New API features in Archicad 28
Registration
Technical introduction
Control the Load/Unload Mechanism
Custom panels in settings dialogs
Error Codes
FAQ
GSRoot and STL analogies
Modeless Palettes
Own Data Saved into the Database
Required functions
Required resources
Add-On Management
Library Part Subtypes
Modules
Classes
Class List
Class Index
Class Hierarchy
Class Members
All
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Functions
a
b
c
d
e
f
g
h
i
k
l
m
n
o
p
r
s
t
u
w
~
Variables
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Typedefs
Enumerations
Related Symbols
a
c
f
g
s
•
All
Classes
Namespaces
Functions
Variables
Typedefs
Enumerations
Enumerator
Friends
Modules
Pages
Loading...
Searching...
No Matches
API_BeamType Member List
This is the complete list of members for
API_BeamType
, including all inherited members.
aboveViewLinePen
API_BeamType
aboveViewLineType
API_BeamType
anchorPoint
API_BeamType
beamShape
API_BeamType
begC
API_BeamType
belowViewLinePen
API_BeamType
belowViewLineType
API_BeamType
coverFillBackgroundPen
API_BeamType
coverFillForegroundPen
API_BeamType
coverFillOrientationComesFrom3D
API_BeamType
coverFillTransformation
API_BeamType
coverFillTransformationType
API_BeamType
coverFillType
API_BeamType
curveAngle
API_BeamType
cutContourLinePen
API_BeamType
cutContourLineType
API_BeamType
cutFillBackgroundPen
API_BeamType
cutFillPen
API_BeamType
displayOption
API_BeamType
endC
API_BeamType
head
API_BeamType
hiddenLinePen
API_BeamType
hiddenLineType
API_BeamType
holeContureOn
API_BeamType
holeHeight
API_BeamType
holeLevel
API_BeamType
holeType
API_BeamType
holeWidth
API_BeamType
isAutoOnStoryVisibility
API_BeamType
isFlipped
API_BeamType
isSlanted
API_BeamType
level
API_BeamType
linkToSettings
API_BeamType
nCuts
API_BeamType
nProfiles
API_BeamType
nSchemes
API_BeamType
nSegments
API_BeamType
offset
API_BeamType
overheadProjectionMode
API_BeamType
profileAngle
API_BeamType
refLtype
API_BeamType
refPen
API_BeamType
sequence
API_BeamType
showContourLines
API_BeamType
showReferenceAxis
API_BeamType
slantAngle
API_BeamType
uncutProjectionMode
API_BeamType
useCoverFill
API_BeamType
useCoverFillFromSurface
API_BeamType
verticalCurveHeight
API_BeamType
viewDepthLimitation
API_BeamType
visibility
API_BeamType