Archicad 28 C++ API
Loading...
Searching...
No Matches
API_Box3D Struct Reference

Rectangular region of the model with Z extent. More...

#include <APIdefs_Base.h>

Public Attributes

double xMin
 Minimum value of the x coordinate of the box.
 
double yMin
 Minimum value of the y coordinate of the box.
 
double zMin
 Minimum value of the z coordinate of the box.
 
double xMax
 Maximum value of the x coordinate of the box.
 
double yMax
 Maximum value of the y coordinate of the box.
 
double zMax
 Maximum value of the z coordinate of the box.
 

Detailed Description

Rectangular region of the model with Z extent.

Remarks
It is a rectangle in model coordinates, with vertical information. Always expressed in meters, if no other instructions in the corresponding documentation.