Archicad 28 C++ API
|
The representation of the Project Preferences / Calculation Units Rules tab page. More...
#include <APIdefs_Environment.h>
Public Attributes | |
API_CalcLengthFormat | length |
Length preferences. | |
API_CalcAreaFormat | area |
Area preferences. | |
API_CalcVolumeFormat | volume |
Volume preferences. | |
API_CalcAngleFormat | angle |
Angle preferences. | |
bool | useDisplayedValues |
Represents the "Calculate Totals by" RadioButton. true means that Archicad should use the displayed values in calculations. This way the calculations can be verified manually. false means that Archicad should use the exact values (in double precision) in calculations. | |
The representation of the Project Preferences / Calculation Units Rules tab page.