Archicad 28 C++ API
Loading...
Searching...
No Matches
API_ChangeParamType Struct Reference

Parameters to change a value in a Library Part parameter list. More...

#include <APIdefs_Goodies.h>

Public Attributes

char name [API_NameLen]
 name of the parameter to change as ASCII string (library part parameter names are always ASCII).
 
short index
 parameter index. Required if the name field is empty.
 
Int32 ind1
 1st dimension of array (in case of array modifier)
 
Int32 ind2
 2nd dimension of array (in case of array modifier)
 
GS::uchar_t * uStrValue
 Unicode string parameter value in UTF-16 encoding.
 
double realValue
 numeric parameter value
 
GS::uchar_t valueDescription [API_UAddParNumDescLen]
 Value descriptions for numerical values.
 

Detailed Description

Parameters to change a value in a Library Part parameter list.

Remarks
The target variable can be identified either by name or index. In case of an array variable the ind1 and ind2 fields must be passed to address the array position. The new values should be passed in the strValue or realValue fields, depending on the type of the referenced variable. See the ACAPI_LibraryPart_ChangeAParameter and ACAPI_LibraryPart_OpenParameters functions for utilization.