Archicad 28 C++ API
Loading...
Searching...
No Matches
API_ConditionalElementRule Struct Reference

The representation of a conditional element rule on the Preferences / Calculation Rules tab page. More...

#include <APIdefs_Environment.h>

Public Attributes

API_ConditionalElementPropertyTypeID propertyType
 Type of element property to which the rule is applied.
 
double holeLimit
 Limit of element hole size. Holes smaller than the limit are ignored in calculations.
 
GS::HashSet< API_ElemTypeelementTypes
 List of element types to which the rule is applied.
 

Detailed Description

The representation of a conditional element rule on the Preferences / Calculation Rules tab page.

Since
Archicad 26
Remarks
Valid element types for APIConditionalElementPropertyType_Volume:
  • API_WallID
  • API_SlabID
  • API_RoofID
  • API_ShellID
  • API_BeamID Valid element types for APIConditionalElementPropertyType_Surface:
  • API_WallID
  • API_SlabID
  • API_RoofID
  • API_ShellID Valid element type for APIConditionalElementPropertyType_Length:
  • API_WallID From version 26 the type of the elementTypes member was changed into GS::HashSet<API_ElemType>.