Archicad 28 C++ API
Loading...
Searching...
No Matches
API_CursorSet Struct Reference

Cursor set definition for a user input. More...

#include <APIdefs_Interface.h>

Public Attributes

API_CursorFormID nothingOnCursor
 The cursor form when the cursor is not above any remarkable point.
 
API_CursorFormID pointOnCursor
 The cursor form when the cursor is above a point neig (except wall neigs on the reference line)
 
API_CursorFormID lineOnCursor
 The cursor form when the cursor is above a line neig (except wall reference line)
 
API_CursorFormID refPointOnCursor
 The cursor form when the cursor is above a point neig on wall reference line.
 
API_CursorFormID refLineOnCursor
 The cursor form when the cursor is above the reference line of a wall.
 
API_CursorFormID crossOnCursor
 The cursor form when the cursor is above cross point of elements.
 
API_CursorFormID normalOnCursor
 The cursor form when the cursor is above a line which is perpendicular to the input line.
 
API_CursorFormID tangentOnCursor
 The cursor form when the cursor is above a point of osculation with an arc.
 
API_CursorFormID invalpointCursor
 MISSING.
 
API_CursorFormID areaOnCursor
 Over area.
 
API_CursorFormID lineSurfCrossOnCursor
 Line and surface cross point.
 
API_CursorFormID lineSurfNormOnCursor
 Normal line points of surface.
 
API_CursorFormID surfSurfCrossCursor
 Cross line of two surfaces.
 
API_CursorFormID surfSurfNormOnCursor
 Two surfaces are normal.
 

Detailed Description

Cursor set definition for a user input.

Remarks
For example of using custom cursor sets see ACAPI_UserInput_GetArc.