Archicad 28 C++ API
Loading...
Searching...
No Matches
API_DailyProfileUsage Struct Reference

Describes a daily profile usage contained in Operation Profile. More...

#include <APIdefs_Attributes.h>

Public Attributes

short startMonth
 Start month of the usage (profiled period).
 
short startDay
 Start day of the usage (profiled period).
 
short endMonth
 End month of the usage (profiled period).
 
short endDay
 End day of the usage (profiled period).
 
short recurrence
 Weekly recurrence of the usage. The [1,2,4,8,10,20,40] values correspond to Mon, Tue, Wed, Thu, Fri, Sat, Sun. All of these values can be combined so the max. value is 127.
 
short dailyProfileIndex
 Index of the Daily Profile.
 

Detailed Description

Describes a daily profile usage contained in Operation Profile.