Archicad 28 C++ API
|
Parameters of a drawing link. More...
#include <APIdefs_Database.h>
Public Attributes | |
API_DrawingLinkTypeID | linkTypeID |
Type of the link. | |
API_IDFTypeID | idfTypeID |
Type of the content; can be Drawing, Image, PDF, or undefined. | |
API_Guid | linkGuid |
GUID for internal or external views. | |
IO::Location * | linkPath |
The location of the file associated with the link in case of internal and external views, images, PDF type or API add-on file types. | |
char | name [256] |
The name of the drawing. | |
char | number [256] |
The number of the drawing. | |
API_ViewNodeTypeID | viewType |
The type of the model behind the view (in case of view type links only) ( API_DrawingLink_InternalViewID or API_DrawingLink_ExternalViewID ) | |
bool | viewDeleted |
The destination view is not available (in case of view type links only) | |
GSPtr | viewPath |
Pointer to a dynamically allocated C string containing the path to the source view in the Project Navigator in case of view type links (e.g. "\Untitled\0. Ground Floor") | |
API_DrawingLinkTypeID | infoTypeID |
The original type of the link if it is broken (used only when linkTypeID is API_DrawingLink_InfoID ) | |
Parameters of a drawing link.
linkPath
location is used only for links having associated source file location; otherwise, this pointer is nullptr
. The viewPath
is filled out only for internal and external view type links, otherwise it is nullptr
. If the link has been broken, then the linkTypeID
parameter is @ref API_DrawingLink_InfoID
. In this case the infoTypeID
field shows the original type of the link.