Archicad 28 C++ API
Loading...
Searching...
No Matches
API_ESYMParams Struct Reference

Describes the current external symbol your add-on can work on. More...

#include <APIdefs_Callback.h>

Public Attributes

GSType signature
 A four-character identifier of your external symbol type. It's is the same what you called ACAPI_LibraryPart_InstallESYMHandler with.
 
short method
 The type of the requested operation:
 
Int32 libInd
 The library index of the symbol your add-on was called for.
 
IO::Location * location
 The location of the external symbol your add-on was called for.
 
API_AddParType ** params
 Additional parameters of the external symbol.
 

Detailed Description

Describes the current external symbol your add-on can work on.

Remarks
The is the parameter of the APIESYMCommandProc callback function, identifying the external symbol you should work on.

Member Data Documentation

◆ method

API_ESYMParams::method

The type of the requested operation:

Tyype Operation
ESYM_NEW Archicad opened a new external symbol for your add-on; the user chose your external symbol type from the New Library Part menu.
ESYM_EDIT The user has begun editing one of your external symbols.