Archicad 28 C++ API
Loading...
Searching...
No Matches
API_ElemCategoryValue Struct Reference

Element category value structure. More...

#include <APIdefs_Elements.h>

Public Attributes

API_Guid guid
 GUID of the category value.
 
API_ElemCategory category
 the category of the category value
 
GS::uchar_t name [API_UniLongNameLen]
 Localized name of the category value.
 
bool isVisibleOnUI
 specifies if it is visible on the UI
 
bool usableAsCriteria
 specifies if it is usable as a criteria
 

Detailed Description

Element category value structure.

Remarks
This structure contains the data of an element category value. For available categories check API_ElemCategoryID.