Archicad 28 C++ API
Loading...
Searching...
No Matches
API_ElemDifference Struct Reference

Common structure for the element difference generator components. More...

#include <APIdefs_ElementDifferenceGenerator.h>

Public Attributes

GS::HashSet< API_GuidnewElements
 The new elements.
 
GS::HashSet< API_GuidmodifiedElements
 The modified elements.
 
GS::HashSet< API_GuiddeletedElements
 The deleted elements.
 
bool isEnvironmentChanged
 True if any of the following is changed: the view or the settings of the view, project information or preferences, property definitions, geographical locations.
 

Detailed Description

Common structure for the element difference generator components.

Remarks
This structure specify element difference for the Element difference generator. You can get a elmenet difference by the ACAPI_DifferenceGenerator_GenerateDifference function.