Archicad 28 C++ API
Loading...
Searching...
No Matches
API_ElemDifferenceGeneratorState Struct Reference

Common structure for the element difference generator components. More...

#include <APIdefs_ElementDifferenceGenerator.h>

Public Member Functions

 API_ElemDifferenceGeneratorState (GSConstHandle handle)
 Construct a new API_ElemDifferenceGeneratorState instance with the given statHdl and set to APIDiffState_InMemory.
 
 API_ElemDifferenceGeneratorState (const IO::Location &location)
 Construct a new API_ElemDifferenceGeneratorState instance with the given location and set to APIDiffState_InFile.
 
void operator= (const API_ElemDifferenceGeneratorState &source)
 Copy assignment operator (from a reference to another instance)
 
void operator= (API_ElemDifferenceGeneratorState &&source)
 Move assignment operator (from a reference to another instance)
 

Public Attributes

API_ElemDifferenceGeneratorStateType stateType
 The type of the difference generator state.
 
GSHandle stateHdl
 The effective state of the difference generator, if the stateType is APIDiffState_InMemory.
 
IO::Location fileLocation
 The path of the file, that will be use if the stateType is APIDiffState_InFile.
 
API_Guid viewGuid
 The view guid, that will assure that the difference come from used element change not from the view settings, used only in APIDiff_ContextBased generator.
 

Detailed Description

Common structure for the element difference generator components.

Remarks
This structure specify the difference generator state. You can get a elemenet state by the ACAPI_DifferenceGenerator_GetState function, and use in ACAPI_DifferenceGenerator_GenerateDifference function.

Constructor & Destructor Documentation

◆ API_ElemDifferenceGeneratorState() [1/2]

API_ElemDifferenceGeneratorState::API_ElemDifferenceGeneratorState ( GSConstHandle  handle)
inline

Construct a new API_ElemDifferenceGeneratorState instance with the given statHdl and set to APIDiffState_InMemory.

Parameters
handleThe effective state of the difference generator.

◆ API_ElemDifferenceGeneratorState() [2/2]

API_ElemDifferenceGeneratorState::API_ElemDifferenceGeneratorState ( const IO::Location &  location)
inline

Construct a new API_ElemDifferenceGeneratorState instance with the given location and set to APIDiffState_InFile.

Parameters
locationThe path of the file.

Member Function Documentation

◆ operator=() [1/2]

void API_ElemDifferenceGeneratorState::operator= ( API_ElemDifferenceGeneratorState &&  source)
inline

Move assignment operator (from a reference to another instance)

Parameters
sourceThe other API_ElemDifferenceGeneratorState instance.

◆ operator=() [2/2]

void API_ElemDifferenceGeneratorState::operator= ( const API_ElemDifferenceGeneratorState source)
inline

Copy assignment operator (from a reference to another instance)

Parameters
sourceThe other API_ElemDifferenceGeneratorState instance.