Archicad 28 C++ API
Loading...
Searching...
No Matches
API_FontType Struct Reference

Contains common information related to a font. More...

#include <APIdefs_Environment.h>

Public Attributes

API_Font_Head head
 Specifies the name and index of the font. The flags field in the header specifies whether this is a vectorial font.
 
GSCharCode charCode
 The character code used in the Unicode-ANSI string conversion routines of the GSRoot String Manager.
 
double ascent
 The ascent of the characters (the height above the baseline).
 
double descent
 The descent of the characters (the depth below the baseline).
 
double widMax
 The maximum width of the characters in this font.
 
double externalLeading
 The value of the external leading.
 
short substituteInd
 Attribute ndex of the substitute font.
 

Detailed Description

Contains common information related to a font.