Archicad 28 C++ API
Loading...
Searching...
No Matches
API_GDLModelViewOptions Struct Reference

Represents the GDL related model view options. More...

#include <APIdefs_ViewSettings.hpp>

Public Attributes

GS::uchar_t name [API_UniLongNameLen]
 Name of the options in Unicode format.
 
API_Guid guid
 Unique ID of the option.
 
API_AddParType ** params
 Additional parameters.
 
char checkSum [64]
 MD5 checksum of params (output only).
 
API_Guid supersetGuid
 Unique ID of another GDL-related model view option which has all of the functionality of this one. If that is present, the current one is filled, but not shown in the Model View Options dialog.
 
Int32 filler [4]
 Reserved for later use.
 

Detailed Description

Represents the GDL related model view options.

Remarks
These settings correspond to the relevant items in the Document/Set Model View/Model View Options dialog. Model view options are also part of the navigator view definition. Call the ACAPI_Navigator_GetViewOptions or ACAPI_Navigator_ChangeViewOptions functions to operate on this data. Do not forget to dispose the gdlOptions pointer when it is not needed any more. Refer to the ACAPI_FreeGDLModelViewOptionsPtr to do that.